Domino on Linux/Unix, Troubleshooting, Best Practices, Tips and more ...

Traveler Install requires configured server to detect Domino version

Daniel Nashed  31 December 2019 21:48:11
Now that the second customer ran into it, let me explain why this happens and how to prevent it.

Traveler 10.0.1.2 and Traveler 11 can be installed on top of Domino 9/10/11.

All 3 different Domino releases need different Traveler binaries to be installed.
Therefore it is essential that the Traveler setup can detect your Domino version.

The current Java routine only works if the Domino server is configured and has a vaild server.id.

Traveler 10.0.1.2 does assume Domino 11 if no platform can be determined.

In that case on a Domino 10.0.1 server you would get the wrong binaries installed, which will not work..

If you are installing a new server, you should configure Domino first before installing Traveler.
In some scenarios you are installing a new machine to take over the data of an existing Traveler server.
To get your server up and running you either have to use a silent install specifying the Domino release explicitly (like we are doing in the Docker project) or you have to copy the basic Domino configuration before installing Traveler.

You find the detected version in the Traveler install log -> /local/notesdata/IBM_TECHNICAL_SUPPORT/traveler/logs/TravelerInstall.log

It looks like this:

Domino returned version string: Release 9.0.1FP10HF382 | November 19, 2018

DominoVersionAction
Domino version detected: 9.0.1

In case you want to use the silent install option, the parameters would be as follows:

INSTALLED_DOMINO_VERSION=10.0.1
BYPASS_DOMINO_VERSION_CHECK=true

I hope this helps

-- Daniel

Archives


  • [IBM Lotus Domino]
  • [Domino on Linux]
  • [Nash!Com]
  • [Daniel Nashed]