Domino on Linux/Unix, Troubleshooting, Best Practices, Tips and more ...

Changes in HTML MIME Rendering cause some odd behaviour

Daniel Nashed  24 May 2010 10:18:07


Since Notes 8 the client uses a different way to render HTML mail. The client uses functionality from the default operating system browser to improve the rendering.
This functionality is used to view and print read-only mails. Since Notes Release 8 I had some issues with this functionality.

- ESC does not always work
- Copying text does sometimes copy the wrong text
- Searching in the document does not work
- Some links are not displayed correctly

Some of those issues have been already technoted and the suggestion is to disable the new rendering via perferences ("Disable Embedded Browser for MIME mail") or directly via notes.ini (BrowserRenderDisable=1).
A Partner also reported that disabling this functionality reduced the number of crashes they had.

I would be interested in your experience with the new HTML rendering.

-- Daniel


Comments

1Chris Miller  24.05.2010 17:55:21  Changes in HTML MIME Rendering cause some odd behaviour

Funny timing as I was just reading and reviewing that book on HTML mail across clients. I have noticed many issues using the built in rendering as well as the format for delivery. { Link }

I disabled the rendering and still saw issues in other ways. I don't think either is the right answer. More work on rendering support needs to be done in the client

2Judy Kilpinen  16.01.2013 0:55:53  Changes in HTML MIME Rendering cause some odd behaviour

After much gnashing of teeth & internet searching I stumbled across your post. MIME emails generated by a LS agent were no longer displaying properly in 8.5.3 mail preview pane, but would display correctly if you opened the email up in edit mode. Once I disabled the embedded browser as per your suggestion & restarted the Notes client, the email displayed properly in the preview pane. That's just too weird.

3Christian Dencker  09.10.2013 16:59:43  Changes in HTML MIME Rendering cause some odd behaviour

Well .... It's still an issue in 9.0 ... before I turn in further PMR's on this .... any news that I'm not aware of ?

4Daniel Nashed  17.10.2013 9:40:24  Changes in HTML MIME Rendering cause some odd behaviour

I am not aware of any changes in 9.0

5Thomas Mezzanotte  06.09.2016 16:58:10  Changes in HTML MIME Rendering cause some odd behaviour

This problem is solved in any patch or disable embedded browser is the solution?

thk

Archives


  • [IBM Lotus Domino]
  • [Domino on Linux]
  • [Nash!Com]
  • [Daniel Nashed]